1989 216 no spark

Having problems with your 200 or 400? This is the place for asking advice and help on technical problems. Resident experts will be on hand to help you keep your car in tip top condition

Moderator: Forum Staff

Message
Author
Goodwoodmm
Posts: 7
Joined: Tue Oct 01, 2019 9:23 pm

1989 216 no spark

#1 Post by Goodwoodmm » Wed Oct 02, 2019 6:41 am

Could anybody point me in the right direction with a no spark issue on my 216. Have replaced coil, crank sensor, leads, distributor cap and Ecu but still nothing!!! Thanks.

User avatar
GTiJohn
Club Chairman
Posts: 4326
Joined: Mon Aug 16, 2010 8:01 pm
Location: Midlands
Contact:

Re: 1989 216 no spark

#2 Post by GTiJohn » Wed Oct 02, 2019 7:40 am

Is this an S-series 216 saloon or a D-series 216 hatchback? '89 could be either...
I like Twin Cams.... and Single Cams

StubbornPatriot
Club Secretary
Posts: 371
Joined: Thu Sep 11, 2014 11:30 pm
Location: Northampton

Re: 1989 216 no spark

#3 Post by StubbornPatriot » Wed Oct 02, 2019 8:27 am

When did the problem start? Has it been running recently? Did you fit a new rotor arm when you changed the distributor cap?
1989 216GSI + 1990 216GSI + 1997 416 Tourer + Triumph T160V

User avatar
1234dist
Club Member
Posts: 6286
Joined: Fri Aug 26, 2011 9:08 pm
Location: Chapel of Dist, Manchester
Contact:

Re: 1989 216 no spark

#4 Post by 1234dist » Wed Oct 02, 2019 8:53 am

If Honda, it’s your distributor
Pastor @ Rover Revival NFP Garage
220 Coupe turbo K785OAT
218 VVC Cabriolet R220OVR
220 GTI M-series J777RAL
75 2.0 CDT P80CJM
620 SLI P267LOM HONDA
420 GSI Turbo L191CVP

User avatar
GTiJohn
Club Chairman
Posts: 4326
Joined: Mon Aug 16, 2010 8:01 pm
Location: Midlands
Contact:

Re: 1989 216 no spark

#5 Post by GTiJohn » Wed Oct 02, 2019 9:47 am

1234dist wrote:
Wed Oct 02, 2019 8:53 am
If Honda, it’s your distributor
That where I was going but it may not be a D :wink3
I like Twin Cams.... and Single Cams

richard moss
Club Member
Posts: 753
Joined: Sat Dec 22, 2007 12:02 am
Location: Al Ain, Abu Dhabi

Re: 1989 216 no spark

#6 Post by richard moss » Wed Oct 02, 2019 5:20 pm

StubbornPatriot wrote:
Wed Oct 02, 2019 8:27 am
Did you fit a new rotor arm when you changed the distributor cap?
Often a problem, often missed
Out in the desert with 2 old Jeeps and a Saab 9-3 cabrio
Back home: wife's 1993 216 DOHC Cabriolet, daughter's R100 and my 1969 MGC GT

Goodwoodmm
Posts: 7
Joined: Tue Oct 01, 2019 9:23 pm

Re: 1989 216 no spark

#7 Post by Goodwoodmm » Wed Oct 02, 2019 6:17 pm

Thanks for all the replies. NOT Honda and a saloon. Nothing from the coil, power in and out but no HT.

Goodwoodmm
Posts: 7
Joined: Tue Oct 01, 2019 9:23 pm

Re: 1989 216 no spark

#8 Post by Goodwoodmm » Wed Oct 02, 2019 6:30 pm

Thanks for all the replies. NOT Honda and a saloon. Nothing from the coil, power in and out but no HT.

User avatar
GTiJohn
Club Chairman
Posts: 4326
Joined: Mon Aug 16, 2010 8:01 pm
Location: Midlands
Contact:

Re: 1989 216 no spark

#9 Post by GTiJohn » Wed Oct 02, 2019 7:07 pm

Goodwoodmm wrote:
Wed Oct 02, 2019 6:30 pm
Thanks for all the replies. NOT Honda and a saloon. Nothing from the coil, power in and out but no HT.
Have you got a 'known good' coil you can try? You might be unlucky and have fitted a duff or incorrect one.
I like Twin Cams.... and Single Cams

220 GSi turbo
Events Secretary
Posts: 1958
Joined: Thu Sep 20, 2007 7:48 pm
Location: The National Forest

Re: 1989 216 no spark

#10 Post by 220 GSi turbo » Wed Oct 02, 2019 7:24 pm

Do you know if you have a 12v (ish) supply to the coil when the ignition is turned on?

Also, check all of the fuses carefully: it is very likely that the main 12v supply to the ECU is fused and if that fuse has blown, the ECU will do nothing.
Is it a carburettor-fed engine, or fuel injection (EFi)?

The whole ignition and fuel system on your car is very similar to that used on the Maestro and Montego, so if anybody else reading this has access to an M&M manual, perhaps they can offer some help :)
1995 220GSi Turbo: owned for 18 years
1994 216SLi
2000 25GTi

Daily: ZR Trophy TD

Previously: 216 Coupe L887PTR(1993-95) 214SLi N219EPO(1995-96) 420GSi Turbo L955UKV(1997-2004) 214SEi M884BMR(2004-11) 420GSi Tourer M650XEX(2005-6) 214 SEi M103BCW(2011-12)

Goodwoodmm
Posts: 7
Joined: Tue Oct 01, 2019 9:23 pm

Re: 1989 216 no spark

#11 Post by Goodwoodmm » Wed Oct 02, 2019 7:55 pm

Thanks for the reply. It’s a carburettor engine. 12v both sides of the coil. Seems to have power to the ecu.

Kriss707
Posts: 105
Joined: Tue Apr 26, 2016 8:57 pm
Location: Cornwall
Contact:

Re: 1989 216 no spark

#12 Post by Kriss707 » Thu Oct 03, 2019 12:15 am

This is a primative way of testing the Coil in situ .... If you connect the Coil + & - direct to the battery + & - then turn the engine, if there's a spark the problem is before the coil. Depending on your electrical system the car may even start this way so make sure its not in gear.

If there's no spark your Coil is duff.

Goodwoodmm
Posts: 7
Joined: Tue Oct 01, 2019 9:23 pm

Re: 1989 216 no spark

#13 Post by Goodwoodmm » Wed Oct 09, 2019 10:24 pm

Still can’t seem to get a spark. Any other thoughts or suggestions?

crepello
Club Member
Posts: 1485
Joined: Thu Feb 18, 2010 2:47 pm
Location: Herts

Re: 1989 216 no spark

#14 Post by crepello » Thu Oct 10, 2019 9:05 am

Is there an electronic igniter amplifier module on the distributor?
On my K8's distributor, this has failed in the past, resulting in no spark.

Goodwoodmm
Posts: 7
Joined: Tue Oct 01, 2019 9:23 pm

Re: 1989 216 no spark

#15 Post by Goodwoodmm » Sat Oct 12, 2019 8:58 am

Thanks. Will have a look 👍

Post Reply