Help with a fueling issue please?

Having problems with your 200 or 400? This is the place for asking advice and help on technical problems. Resident experts will be on hand to help you keep your car in tip top condition

Moderator: Forum Staff

Post Reply
Message
Author
lock1506
Posts: 48
Joined: Mon Feb 12, 2018 8:12 pm

Help with a fueling issue please?

#1 Post by lock1506 » Sat Jun 15, 2019 7:08 pm

Any help greatly appreciated! 1995 214 sli. Fuel pump primes when you turn the key and I've got fuel at the injectors but then when you try to start the car it either hunts as if it is running out of fuel or wont start at all. It runs fine on Easy start being sprayed in through the throttle body, so far I've replaced the relay in the engine bay, the one behind the center console, made sure the fuel cut off is pressed in and I've dropped the tank and replaced the fuel pump with a known good second hand one.
Any suggestions before I start to break it as I've just about had enough of it now.
Thanks Chris.

crepello
Club Member
Posts: 1462
Joined: Thu Feb 18, 2010 2:47 pm
Location: Herts

Re: Help with a fueling issue please?

#2 Post by crepello » Sat Jun 15, 2019 8:04 pm

Some of what you say sounds like 216-speak!
Either way, a dodgy crank angle sensor could confuse the ECU as to injector timing.
There's also this to consider!
Last edited by crepello on Sat Jun 15, 2019 9:10 pm, edited 1 time in total.

lock1506
Posts: 48
Joined: Mon Feb 12, 2018 8:12 pm

Re: Help with a fueling issue please?

#3 Post by lock1506 » Sat Jun 15, 2019 9:09 pm

Hi its a 14 rover K, I have already changed the crankshaft sensor as well, I forgot to mention that, suppose it could be a dodgy new one. I've got another one on the shelf, will give it a go just in case. Thankyou.

User avatar
1234dist
Club Member
Posts: 6191
Joined: Fri Aug 26, 2011 9:08 pm
Location: Chapel of Dist, Manchester
Contact:

Re: Help with a fueling issue please?

#4 Post by 1234dist » Sat Jun 15, 2019 10:47 pm

Can you post a video of it running?
Just upload to YouTube and post a link.
Pastor @ Rover Revival NFP Garage
220 Coupe turbo K785OAT
218 VVC Cabriolet R220OVR
220 GTI M-series J777RAL
75 2.0 CDT P80CJM
620 SLI P267LOM HONDA
420 GSI Turbo L191CVP

lock1506
Posts: 48
Joined: Mon Feb 12, 2018 8:12 pm

Re: Help with a fueling issue please?

#5 Post by lock1506 » Sun Jun 16, 2019 5:58 pm

No sorry, just had a quick mess on in between showers today and I've ran out of Easy start. The best I can get without it today is it tries to fire when the pump has first primed then thats it. I'll try another crank sensor if I get a chance during the week then after that I'm starting to think immobilizer fault or ECU.

lock1506
Posts: 48
Joined: Mon Feb 12, 2018 8:12 pm

Re: Help with a fueling issue please?

#6 Post by lock1506 » Mon Jun 17, 2019 5:46 pm

Well I've just replaced the new crank sensor with another new one I had on the shelf and it fired straight up and is running perfect! Not sure if this is just luck and the intermittent fault is still there, time will tell but at the moment thats a big improvement.
My car has the sensor with the blue plug on and when I replaced it the first time I didn't take much notice of the one I took out and it is long gone now. However its replacement was a Valeo one which had a slim red wire and a blue wire where as the one I've put in today has a much thicker grey wire and a thick black wire, still with the same blue plug on the end. At the moment I am thinking the Valeo one must have been faulty from new.

crepello
Club Member
Posts: 1462
Joined: Thu Feb 18, 2010 2:47 pm
Location: Herts

Re: Help with a fueling issue please?

#7 Post by crepello » Mon Jun 17, 2019 8:32 pm

Just shows what happens when the Club steps up to help!

lock1506
Posts: 48
Joined: Mon Feb 12, 2018 8:12 pm

Re: Help with a fueling issue please?

#8 Post by lock1506 » Fri Jun 21, 2019 5:25 pm

Fault still there, car fired up straight away on Monday night and ran fine, went to move it tonight and give it a quick run around the block to make sure it was still ok ready for mot tomorrow and once again it won't start.
Now breaking, I'll list it on ebay as breaking and in the for sale section, if anyone wants any big bits I can bring them down to the Festival of the Unexceptional.

lock1506
Posts: 48
Joined: Mon Feb 12, 2018 8:12 pm

Re: Help with a fueling issue please?

#9 Post by lock1506 » Mon Sep 09, 2019 4:27 pm

Just to finish this post off, I didn't break this in the end. I walked away and left it for awhile then as in my other post it was an ECU fault and the first replacement ECU was also faulty. So with a second new ECU it is running well again, mot'd and back on the road so I can enjoy driving it again.

richard moss
Club Member
Posts: 734
Joined: Sat Dec 22, 2007 12:02 am
Location: Al Ain, Abu Dhabi

Re: Help with a fueling issue please?

#10 Post by richard moss » Mon Sep 09, 2019 4:42 pm

I'm glad to hear that it lived
Out in the desert with 2 old Jeeps and a Saab 9-3 cabrio
Back home: wife's 1993 216 DOHC Cabriolet, daughter's R100 and my 1969 MGC GT

Post Reply