Engine wiring

Having problems with your 200 or 400? This is the place for asking advice and help on technical problems. Resident experts will be on hand to help you keep your car in tip top condition

Moderator: Forum Staff

Message
Author
JOHNDQ
Posts: 580
Joined: Sat Mar 25, 2017 12:38 am

Re: Engine wiring

#16 Post by JOHNDQ » Sun Sep 06, 2020 9:16 pm

If the ignition coil and spark plugs are not firing first place I would look is the crankshaft sensor

Xtrmjks
Posts: 24
Joined: Sun Aug 09, 2020 7:15 am

Re: Engine wiring

#17 Post by Xtrmjks » Mon Sep 07, 2020 6:46 am

JOHNDQ wrote:
Sun Sep 06, 2020 9:16 pm
If the ignition coil and spark plugs are not firing first place I would look is the crankshaft sensor
Crank sensor has been tested . There’s signal to ecu plug.

User avatar
220 GSi turbo
Events Secretary
Posts: 2177
Joined: Thu Sep 20, 2007 7:48 pm
Location: The National Forest

Re: Engine wiring

#18 Post by 220 GSi turbo » Mon Sep 07, 2020 9:32 pm

I think you might still have an immobiliser-related issue.

I have just tried an experiment on my wife's Rover 114: I let the immobiliser set itself (30 seconds after the engine has been switched off) and then tried to start the car.

As soon as I turned the ignition on, the fuel pump primed. Obviously the car would not start, as the immobiliser had taken out the starter circuit, ignition, etc. It would appear that the fuel pump circuit is not disabled by the immobiliser.

I am thinking that the immobiliser bypass that you think has been done on your system has not been done correctly, so your engine ECU is not providing any spark or injector commands.

I would suggest that forum member 'Bobbybrown' might be able to help you sort this.
1995 220GSi Turbo: owned for 19 years
1994 216SLi
2000 25GTi

Daily: ZR Trophy TD

Previously: 216 Coupe L887PTR(1993-95) 214SLi N219EPO(1995-96) 420GSi Turbo L955UKV(1997-2004) 214SEi M884BMR(2004-11) 420GSi Tourer M650XEX(2005-6) 214 SEi M103BCW(2011-12)

Xtrmjks
Posts: 24
Joined: Sun Aug 09, 2020 7:15 am

Re: Engine wiring

#19 Post by Xtrmjks » Tue Sep 08, 2020 6:27 am

I have tried to contact him. No reply.

User avatar
220 GSi turbo
Events Secretary
Posts: 2177
Joined: Thu Sep 20, 2007 7:48 pm
Location: The National Forest

Re: Engine wiring

#20 Post by 220 GSi turbo » Tue Sep 08, 2020 8:24 am

OK, try Paul at Technozen Electronics: https://www.technozen-electronics.co.uk/

Alternatively, if you are thinking of going for a remap for more power, a remapping specialist can probably disable the immobiliser permanently at the same time.
1995 220GSi Turbo: owned for 19 years
1994 216SLi
2000 25GTi

Daily: ZR Trophy TD

Previously: 216 Coupe L887PTR(1993-95) 214SLi N219EPO(1995-96) 420GSi Turbo L955UKV(1997-2004) 214SEi M884BMR(2004-11) 420GSi Tourer M650XEX(2005-6) 214 SEi M103BCW(2011-12)

Xtrmjks
Posts: 24
Joined: Sun Aug 09, 2020 7:15 am

Re: Engine wiring

#21 Post by Xtrmjks » Wed Sep 09, 2020 6:27 am

I’ve got a reply from Paul, “I don't believe this is an immobiliser issue as the engine ECU only stops
the injector drive when immobilised, the ignition coil drive is not affected.”

User avatar
220 GSi turbo
Events Secretary
Posts: 2177
Joined: Thu Sep 20, 2007 7:48 pm
Location: The National Forest

Re: Engine wiring

#22 Post by 220 GSi turbo » Wed Sep 09, 2020 8:38 am

Thanks for the feedback :)

So if you have no spark (have you tested this at the 'king lead' straight out of the top of the coil, or used a spark plug at the end of one of the plug leads?), you have tried another coil and you are confident that the crank sensor and its circuit are ok, this is starting to sound like an ECU fault. Unusual, but still possible.
1995 220GSi Turbo: owned for 19 years
1994 216SLi
2000 25GTi

Daily: ZR Trophy TD

Previously: 216 Coupe L887PTR(1993-95) 214SLi N219EPO(1995-96) 420GSi Turbo L955UKV(1997-2004) 214SEi M884BMR(2004-11) 420GSi Tourer M650XEX(2005-6) 214 SEi M103BCW(2011-12)

Xtrmjks
Posts: 24
Joined: Sun Aug 09, 2020 7:15 am

Re: Engine wiring

#23 Post by Xtrmjks » Wed Sep 09, 2020 10:31 am

I’ve tried several coils. There’s no beg pulse to coil from ecu. I’m thinking ecu fault as well..

961tat
Club Member
Posts: 707
Joined: Fri Apr 29, 2016 7:19 pm
Location: Lancaster

Re: Engine wiring

#24 Post by 961tat » Wed Sep 09, 2020 11:29 am

What number is the ecu i have a few here that work and matching 5as and fob .

Xtrmjks
Posts: 24
Joined: Sun Aug 09, 2020 7:15 am

Re: Engine wiring

#25 Post by Xtrmjks » Wed Sep 09, 2020 12:08 pm

Ecu is mkc103400, engine is in a kit car, so no fobs or immobiliser.

Post Reply