will not start. immobiliser needs to be disengaged?

Having problems with your 200 or 400? This is the place for asking advice and help on technical problems. Resident experts will be on hand to help you keep your car in tip top condition

Moderator: Forum Staff

Message
Author
User avatar
GTiJohn
Club Chairman
Posts: 4947
Joined: Mon Aug 16, 2010 8:01 pm
Location: Midlands
Contact:

Re: will not start. immobiliser needs to be disengaged?

#16 Post by GTiJohn » Wed Jan 29, 2014 7:45 pm

Getting back to the immobilisation/CDL theme....

I disconnected the battery at the weekend to do some stuff but on reconnecting it things had changed....

The CDL is no longer doing anything. I can neither lock or unlock the car via the remote so the passenger door lock no longer responds either. The good news is that the immobiliser is now inactive too.

I'm just using the key in the door lock and trying to remember to lock the passenger door manually.

Any ideas ?

I think the driver's door actuator might have just lost its last signs of life.

So I'm after another one. The car is an M-reg, if that makes any difference. I've seen both '2 wire' and '4 wire' types being advertised on ebay but only passenger-side ones....
I like Twin Cams.... and Single Cams

User avatar
GTiJohn
Club Chairman
Posts: 4947
Joined: Mon Aug 16, 2010 8:01 pm
Location: Midlands
Contact:

Re: will not start. immobiliser needs to be disengaged?

#17 Post by GTiJohn » Wed Apr 16, 2014 9:17 pm

It's gone again :mope

At least it's in the garage and not somewhere else....like Cofton Park :laughing2

Locking and unlocking the car has triggered the immobiliser.

Both fobs seem to have had better days and only one button on each feels as if it's actually clicking.

Further battery swapage has not changed anything, so I'm now looking at reconditioned fobs re-coded to my 5AS control unit on ebay.

Has anybody got any experience of this ?
I like Twin Cams.... and Single Cams

User avatar
RoverRevival
Club Member
Posts: 6917
Joined: Fri Aug 26, 2011 9:08 pm
Location: RoverRevival, Manchester
Contact:

Re: will not start. immobiliser needs to be disengaged?

#18 Post by RoverRevival » Wed Apr 16, 2014 9:21 pm

bobby brown on rt can either re-program you ecu and give you new fobs or I can give you a quicker way of bypassing but not on open forum. (the way for older versions).
Pastor @ Rover Revival NFP Garage
220 Coupe turbo K785OAT
218 VVC Cabriolet R220OVR
Mercedes C270 diesel P80CJM
620 SLI P267LOM HONDA
For Sale:
75 1.8 auto Connie 70k copperleaf
25 Streetwise 54k
620 SLI Honda 60k
& C3

E_T_V
Technical Advisor
Posts: 3010
Joined: Tue Nov 07, 2006 8:25 pm
Location: Scunthorpe
Contact:

Re: will not start. immobiliser needs to be disengaged?

#19 Post by E_T_V » Wed Apr 16, 2014 10:41 pm

Check the soldering connections on the PCB boards as they can crack giving problems.

Also try disconnecting the wiring for the door lock. It is possible that it is broken and stopping the immobiliser activating/deactivating.

Otherwise have a chat with bobbybrown from rovertech as he offers this service.

User avatar
GTiJohn
Club Chairman
Posts: 4947
Joined: Mon Aug 16, 2010 8:01 pm
Location: Midlands
Contact:

Re: will not start. immobiliser needs to be disengaged?

#20 Post by GTiJohn » Sat Apr 19, 2014 9:39 am

1234dist wrote:bobby brown on rt can either re-program you ecu and give you new fobs or I can give you a quicker way of bypassing but not on open forum. (the way for older versions).
Bobby (is that his real name ?) is coming over on Sunday to do his magic with my 5AS unit and renew my fobs.

Great help so far - thanks for the tip.

Also RoverTech forum seems very lively and useful - there go several more hours of my life ! :laughing2
I like Twin Cams.... and Single Cams

Bobbybrown
Posts: 31
Joined: Mon Dec 04, 2006 1:33 am

Re: will not start. immobiliser needs to be disengaged?

#21 Post by Bobbybrown » Sun Apr 20, 2014 1:48 pm

All sorted now John, nice to meet you today!
Enjoy the new fobs, your old ones really were terrible haha!

User avatar
RoverRevival
Club Member
Posts: 6917
Joined: Fri Aug 26, 2011 9:08 pm
Location: RoverRevival, Manchester
Contact:

Re: will not start. immobiliser needs to be disengaged?

#22 Post by RoverRevival » Sun Apr 20, 2014 3:37 pm

nice one bobby, :clapping
Pastor @ Rover Revival NFP Garage
220 Coupe turbo K785OAT
218 VVC Cabriolet R220OVR
Mercedes C270 diesel P80CJM
620 SLI P267LOM HONDA
For Sale:
75 1.8 auto Connie 70k copperleaf
25 Streetwise 54k
620 SLI Honda 60k
& C3

Bobbybrown
Posts: 31
Joined: Mon Dec 04, 2006 1:33 am

Re: will not start. immobiliser needs to be disengaged?

#23 Post by Bobbybrown » Sun Apr 20, 2014 6:19 pm

Not seen you around for a while pope *laughs*

User avatar
RoverRevival
Club Member
Posts: 6917
Joined: Fri Aug 26, 2011 9:08 pm
Location: RoverRevival, Manchester
Contact:

Re: will not start. immobiliser needs to be disengaged?

#24 Post by RoverRevival » Sun Apr 20, 2014 6:31 pm

:laughing2 yeah, not on RT anymore but still promote your work.
Pastor @ Rover Revival NFP Garage
220 Coupe turbo K785OAT
218 VVC Cabriolet R220OVR
Mercedes C270 diesel P80CJM
620 SLI P267LOM HONDA
For Sale:
75 1.8 auto Connie 70k copperleaf
25 Streetwise 54k
620 SLI Honda 60k
& C3

User avatar
GTiJohn
Club Chairman
Posts: 4947
Joined: Mon Aug 16, 2010 8:01 pm
Location: Midlands
Contact:

Re: will not start. immobiliser needs to be disengaged?

#25 Post by GTiJohn » Sun Apr 20, 2014 7:05 pm

Bobbybrown wrote:All sorted now John, nice to meet you today!
Enjoy the new fobs, your old ones really were terrible haha!
:welcome

Thanks Dan (aka Bobby) - great to meet you too. And on Easter Sunday too

Things are working as expected now. I'll see how the CDL works when I change the drivers door motor (tomorrow?) but at the mo the fob has to be very near the drivers A-post or preferably inside the cabin.

Very happy to have the car mobile again :D
I like Twin Cams.... and Single Cams

Bobbybrown
Posts: 31
Joined: Mon Dec 04, 2006 1:33 am

Re: will not start. immobiliser needs to be disengaged?

#26 Post by Bobbybrown » Sun Apr 20, 2014 7:15 pm

There is an antenna wire connected under the dash, if you unravel it (usually coiled up) that helps with range.

I've seen you promoting my work on a few forums buddy. Massive Appreciation!

User avatar
RoverRevival
Club Member
Posts: 6917
Joined: Fri Aug 26, 2011 9:08 pm
Location: RoverRevival, Manchester
Contact:

Re: will not start. immobiliser needs to be disengaged?

#27 Post by RoverRevival » Sun Apr 20, 2014 7:45 pm

You do a grand job, you don't over charge and more importantly just because you can't do it, doesn't stop you trying to find out how. All that and advice for free, you the man and I'm happy to promote :cool
Pastor @ Rover Revival NFP Garage
220 Coupe turbo K785OAT
218 VVC Cabriolet R220OVR
Mercedes C270 diesel P80CJM
620 SLI P267LOM HONDA
For Sale:
75 1.8 auto Connie 70k copperleaf
25 Streetwise 54k
620 SLI Honda 60k
& C3

Bobbybrown
Posts: 31
Joined: Mon Dec 04, 2006 1:33 am

Re: will not start. immobiliser needs to be disengaged?

#28 Post by Bobbybrown » Sun Apr 20, 2014 7:55 pm

:D cheers dude! Try to keep costs low so it's convenient and good value for the customers and just about covers my time and fuel costs when I do mobile :) usually break even on the cost of the refurbished fobs but low prices are the name of the game!

User avatar
GTiJohn
Club Chairman
Posts: 4947
Joined: Mon Aug 16, 2010 8:01 pm
Location: Midlands
Contact:

Re: will not start. immobiliser needs to be disengaged?

#29 Post by GTiJohn » Mon Apr 21, 2014 3:15 pm

Couldn't find the antenna anywhere but having changed the driver's side CDL motor so that both doors lock and unlock on the remote, I appear to have a little more range.

I can stand by the car and it works , so I'll leave it at that for a while.

Also waxoyled the inner door bottom, refitted the door shedder and had a go at improving the rigidity of the armrest by adding an internal stiffener.

Good morning's work all round :D
I like Twin Cams.... and Single Cams

User avatar
GTiJohn
Club Chairman
Posts: 4947
Joined: Mon Aug 16, 2010 8:01 pm
Location: Midlands
Contact:

Re: will not start. immobiliser needs to be disengaged?

#30 Post by GTiJohn » Fri Apr 25, 2014 9:38 am

I'm like a kid with a new toy :D

The pleasure I get from simply unlocking the car using the fob has surprised me :*laughs*
I like Twin Cams.... and Single Cams

Post Reply